Sign Up Now FAQ
Signup Now
In order to make a post or to start a new thread and or to interact with other
members of this board, you wil need to create an account first.
If this is your first visit, be sure to check out the FAQ. You have to register before you can post. If you have any problems, please contact us.
Flash a phone to Cricket Wireless Become a supporting member of Cricket Users Forum

 
Welcome to Cricket Users!



Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18
  1. #1
    Junior Member
    Points: 550, Level: 10
    Overall activity: 52.0%

    Reputation
    Reputation 10
    Join Date
    Feb 2012
    Location
    Albuquerque, NM
    Posts
    8



    Mercury will not power on.

    Hello, I was watching a youtube video and when it finished, the screen remained black, then I pressed the home key and the screen was showing the lock-screen, but it was inverted. The phone froze on the lock-screen; it would not turn off, and the keys would not respond at all. Stayed like that for 5 minutes, but it was still frozen on the same screen. Removed the battery, placed it back in, and it will no longer power on at all. Connected the phone to the charger, waited a few minutes, but had no success either.
    Removed the battery and the charger and waited a few minutes. I've tried all sorts of button combination, with and without the battery, with and without the charger. The phone does not respond at all. No lights, no screen, no anything.

    Does anybody have any idea what I can do to fix my phone? Does the phone have a factory warranty? Any help is appreciated. Thank you for your time.

  2. Remove this advertisement.
  3. #2
    Senior Member
    Points: 7,698, Level: 58
    Overall activity: 0%
    captainkirks's Avatar
    Reputation
    Reputation 72
    Join Date
    Nov 2011
    Location
    Madera, Calif
    Posts
    760


    1 out of 1 members liked this post.

    It comes with a one year factory warranty. Plug the charger in and see if it shows charging. You might try a hard reset also. The hard reset will make you lose all your information.

  4. #3
    Junior Member
    Points: 550, Level: 10
    Overall activity: 52.0%

    Reputation
    Reputation 10
    Join Date
    Feb 2012
    Location
    Albuquerque, NM
    Posts
    8



    Thank you for the response; the phone shows no response at all when plugged into the charger, with or without battery. Black screen, no sound, no vibration, zero everything. Unable to boot into recovery either. Not even by trying the un-brick method with ubuntu.

  5. #4
    Senior Member
    Points: 7,698, Level: 58
    Overall activity: 0%
    captainkirks's Avatar
    Reputation
    Reputation 72
    Join Date
    Nov 2011
    Location
    Madera, Calif
    Posts
    760


    1 out of 1 members liked this post.

    I would take it back for an exchange.

  6. #5
    Banned
    Points: 2,650, Level: 31
    Overall activity: 1.0%

    Reputation
    Reputation 31
    Join Date
    Dec 2011
    Location
    na
    Posts
    529



    Have you tried getting it into flash mode.. On a pc with the drivers installed.. REMOVE THE BATTERY .. Put the back of the phone back on with Battery out. (there is a sensor that knows back is off). Plug the phone to the pc thru usb cable.. Then try to holding vol = and vol- together then holding in power button. If this works you will see the static buttons lite up for a second then the phone will boot to a PINKISH Color screen. If this works Then follow the unbricking method in this forum. If the computer does not recognize it at all then its likely hardware trouble .

    How old is the phone . how long have you had it . Please let us know if you end up calling in for warranty .. Curious to see what type of support you get . DO NOT TELL THEM YOU WERE TRYING TO FLASH IT .
    GOOD LUCK .

  7. #6
    Recognized Dev |Łĝıť.|
    Points: 42,850, Level: 100
    Overall activity: 2.0%
    oriax123's Avatar
    Reputation
    Reputation 133
    Join Date
    May 2011
    Location
    Alamo, Texas
    Posts
    2,042



    Staying on the black screen, had the same problem with my old mercury i went to get replaced but i bricked mine on purpose. I bricked mine by formatting all partitions lol anyways im sure you can get it replaced just take it back with your reciept. Make sure you tried everything before you take it.

    Sent from my M886 using Tapatalk 2 Beta-3
    Buy me a drink: Donate
    iPhone Toolbox: Link
    MEID Converter: Link
    Fastroot Toolbox: Link
    NvItem Generator: Link

    If I helped you, please click '*' at the bottom left of that post.

  8. #7
    Junior Member
    Points: 550, Level: 10
    Overall activity: 52.0%

    Reputation
    Reputation 10
    Join Date
    Feb 2012
    Location
    Albuquerque, NM
    Posts
    8



    Phone is less than a month old. Called tech support and the guy was an idiot. "Remove the battery, place it back in, press the power button...take the phone to the store."
    BEST. TROUBLESHOOTING. EVER.

    Being bilingual, I called the Spanish line, and the guy was more polite, but the troubleshooting was horrid. I was told the same thing.

    Next day (today) I took it to the main store...
    Tech "How can I help you?"
    Me "I would like to get my phone replaced!"
    T"Under the insurance?"
    M"No, under the warranty."
    T"Let me see the phone"...looked at the phone for half a second while on my hand and said: "I don't have any of those, come back tomorrow!" Turned around and went back inside his office.

    WTF?
    I was told that I had to pay a ~$25 warranty fee. Is this correct? Customer service is really bad.

    Sent from my M886 using Tapatalk
    Last edited by KingDNH; 03-27-2012 at 02:04 PM.

  9. #8
    Recognized Dev |Łĝıť.|
    Points: 42,850, Level: 100
    Overall activity: 2.0%
    oriax123's Avatar
    Reputation
    Reputation 133
    Join Date
    May 2011
    Location
    Alamo, Texas
    Posts
    2,042



    Quote Originally Posted by KingDNH View Post
    Phone is less than a month old. Called tech support and the guy was an idiot. "Remove the battery, place it back in, press the power button...take the phone to the store."
    BEST. TROUBLESHOOTING. EVER.

    Being bilingual, I called the Spanish line, and the guy was more polite, but the troubleshooting was horrid. I was told the same thing.

    Next day (today) I took it to the main store...
    "How can I help you?"

    Sent from my M886 using Tapatalk
    Yea i never call support as this phone is still new to them (tech wise). They think everything can be fixed with a simple reboot. Always take it to the main store, always glad to help unless you bricked all their mercurys then theyll get mad bcz they lose dinero

    Sent from my M886 using Tapatalk 2 Beta-3
    Buy me a drink: Donate
    iPhone Toolbox: Link
    MEID Converter: Link
    Fastroot Toolbox: Link
    NvItem Generator: Link

    If I helped you, please click '*' at the bottom left of that post.

  10. #9
    Junior Member
    Points: 550, Level: 10
    Overall activity: 52.0%

    Reputation
    Reputation 10
    Join Date
    Feb 2012
    Location
    Albuquerque, NM
    Posts
    8



    Edited last post. Reply button was too close to the cursor and I fat-fingered it.

    Sent from my M886 using Tapatalk
    Last edited by KingDNH; 03-27-2012 at 02:07 PM.

  11. #10
    Recognized Dev |Łĝıť.|
    Points: 42,850, Level: 100
    Overall activity: 2.0%
    oriax123's Avatar
    Reputation
    Reputation 133
    Join Date
    May 2011
    Location
    Alamo, Texas
    Posts
    2,042



    Some charge $20-30. but if it happened within few days of getting the phone then for free.

    Sent from my M886 using Tapatalk 2 Beta-3
    Buy me a drink: Donate
    iPhone Toolbox: Link
    MEID Converter: Link
    Fastroot Toolbox: Link
    NvItem Generator: Link

    If I helped you, please click '*' at the bottom left of that post.

  12. #11
    Junior Member
    Points: 115, Level: 2
    Overall activity: 0%

    Reputation
    Reputation 10
    Join Date
    Sep 2012
    Posts
    1



    SAME PROBLEM. I have a m886 huawei mercury, 3days old. the battery was taken out. then when i put the battery back in my device does not restart

  13. #12
    Member
    Points: 2,171, Level: 28
    Overall activity: 0%

    Reputation
    Reputation 12
    Join Date
    Jun 2011
    Posts
    159



    Well, I now have this problem. Everything was working just fine. I partitioned my SD Card and rebooted the phone and it powered off and that was that. I plug the charger in and nothing, no light on the top left that it's charging. No power to come on. I can't even get into the Pink screen. I used Partition Magic on my PC to make the partition on the SD Card. I have done this before on several phones and this has never happened. My warranty is out. I got the phone Dec. of last year. So, What can I do to make it work again???

  14. #13
    Senior Member
    Points: 17,819, Level: 84
    Overall activity: 20.0%
    indica's Avatar
    Reputation
    Reputation 61
    Join Date
    Nov 2011
    Customer Since
    jan 2011
    Location
    chicago, IL
    Posts
    1,228
    Phone
    samsung Chrono



    Quote Originally Posted by Eaglewtchr View Post
    My warranty is out. I got the phone Dec. of last year. So, What can I do to make it work again???
    ouch, i think a lot of these have bad power control chips in them. one thing to try is a new battery. they are not too expensive from ebay or amazon or go to your local stores and see if they will let you try it before you buy it.

    if that does not work it looks like you are screwed, sorry man. we have a lot of good deals at the store . .. for new lines

    except the S3, with $150 mail in rebate and $50 off it makes cricket the cheapest in our area for an s3. my cousin just paid $200 on top of a 2 year contract for her s3.
    Last edited by indica; 12-19-2012 at 09:50 AM.

  15. #14
    Member
    Points: 234, Level: 4
    Overall activity: 16.0%
    Dom Luvz Rey's Avatar
    Reputation
    Reputation 10
    Join Date
    Feb 2013
    Customer Since
    Feb 2010
    Location
    Anywhere, Colorado
    Posts
    33
    Phone
    Huawei mercury M88



    Question

    Quote Originally Posted by indica View Post
    ouch, i think a lot of these have bad power control chips in them. one thing to try is a new battery. they are not too expensive from ebay or amazon or go to your local stores and see if they will let you try it before you buy it.

    if that does not work it looks like you are screwed, sorry man. we have a lot of good deals at the store . .. for new lines

    except the S3, with $150 mail in rebate and $50 off it makes cricket the cheapest in our area for an s3. my cousin just paid $200 on top of a 2 year contract for her s3.

    My phone is also doing this same exact thing, thing is, it was working just fine before this one person told me to put this one update on it, since the update it will not power on, the red led indicator no longer flashes where you connect the phone by USB Can't no longer get to the pink screen or blue screen which was able before this damn update. Did every single thing you did, as far as removing battery, replacing cover, plugging back in etc? Do you happen to have the exact mercury drivers? Maybe i'm missing something here? IDK, but its possible. I even removed the dload file with the update in it that i was told to put on the phone. Originally, It went through the damn update once, then again a second time, It took about 45 minutes, then next thing you know it never responded again after that no matter what i did. Still haven't gave up, not in a situation where i can buy a brand new phone for the heck of it!

  16. #15
    Member
    Points: 1,374, Level: 20
    Overall activity: 23.0%

    Reputation
    Reputation 10
    Join Date
    Aug 2012
    Customer Since
    July 2010
    Location
    Sacramento Ca.
    Posts
    80



    I see you've described this issue in other threads, this particular thread you've revived is around 5 months old. You're probably new to forums, which I understand, but its always a good idea to check the date of a post before responding to it.

    Sent from my Nexus 4 using Tapatalk 2

 

 
Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Advertise With Us?
Advertise with us? (Position 1 - Advertise with Us) Advertise with us? (Position 2 - QualityCricketPhones) Advertise with us? (Position 3 - Advertise with Us) Advertise with us? (Position 4 - Advertise with Us) Small Banner