Sign Up Now FAQ
Signup Now
In order to make a post or to start a new thread and or to interact with other
members of this board, you wil need to create an account first.
If this is your first visit, be sure to check out the FAQ. You have to register before you can post. If you have any problems, please contact us.
Flash a phone to Cricket Wireless Become a supporting member of Cricket Users Forum

 
Welcome to Cricket Users!



Results 1 to 9 of 9
  1. #1
    Member
    Points: 1,140, Level: 18
    Overall activity: 0%
    Angel Longoria Mena's Avatar
    Reputation
    Reputation 9
    Join Date
    Mar 2012
    Location
    Mercedes, Texas
    Posts
    82
    Phone
    Huawei Mercury



    my mercury finally gave me a problem

    i was watching a video on youtube then the touch screen was lagging.
    i took out the battery and the little LED light was blinking all colors and wouldn't turn on. now that it turns on the touch screen doesn't respond. and the LED light thing still flashes...my phone is off and as soon as i put the battery on. the LED light turns on. idk what is going on. my merc was working perfectly.
    Last edited by Angel Longoria Mena; 09-01-2013 at 06:46 PM.

  2. Remove this advertisement.
  3. #2
    Senior Member
    Points: 22,444, Level: 93
    Overall activity: 0%
    Android Titan's Avatar
    Reputation
    Reputation 52
    Join Date
    Mar 2012
    Location
    portland oregon
    Posts
    761
    Phone
    Galaxy S3



    Its not anything you did its just poor manufacturing the mercury was sloped together the chines didn't care about the quality, they sold us and if you ever look the honor or glory there built a lot better and have much better software

    Sent from my SCH-R530C using Tapatalk 2

  4. #3
    Member
    Points: 1,140, Level: 18
    Overall activity: 0%
    Angel Longoria Mena's Avatar
    Reputation
    Reputation 9
    Join Date
    Mar 2012
    Location
    Mercedes, Texas
    Posts
    82
    Phone
    Huawei Mercury



    dang.. well i got it to kinda work. i did a back up. factory reset. and it worked. but the LED light is still on and the phone lags randomly. bleh.. i think im going to get that admire 2

  5. #4
    Jumpmaster
    Points: 2,456,084, Level: 100
    Overall activity: 0%
    Chris Rodriguez's Avatar
    Reputation
    Reputation 456
    Join Date
    Oct 2010
    Customer Since
    Sept 2010
    Location
    Des Moines, IA
    Posts
    4,421
    Phone
    Note 3 / Galaxy S5


    1 out of 1 members liked this post.

    Yeah Huawei kind of dropped this phone early right after delivery.

    Admire 2 is a pretty nice phone for the $$. @49.99 definitely a deal. Anywhere below 150... Not too bad.
    Please check the forum and post there before PMing me. I have over 674 unread PMs due to the fact that they are issues which should have been addressed here.

    If you need to buy something from (Ebay), please use this LINK every time and support the forum!

  6. #5
    Senior Member
    Points: 22,444, Level: 93
    Overall activity: 0%
    Android Titan's Avatar
    Reputation
    Reputation 52
    Join Date
    Mar 2012
    Location
    portland oregon
    Posts
    761
    Phone
    Galaxy S3



    Quote Originally Posted by Angel Longoria Mena View Post
    dang.. well i got it to kinda work. i did a back up. factory reset. and it worked. but the LED light is still on and the phone lags randomly. bleh.. i think im going to get that admire 2
    Why don't you load the stock ROM and see what happens or is that what you did

    Sent from my SCH-R530C using Tapatalk 2

  7. #6
    Member
    Points: 1,140, Level: 18
    Overall activity: 0%
    Angel Longoria Mena's Avatar
    Reputation
    Reputation 9
    Join Date
    Mar 2012
    Location
    Mercedes, Texas
    Posts
    82
    Phone
    Huawei Mercury



    Quote Originally Posted by Chris Rodriguez View Post
    Yeah Huawei kind of dropped this phone early right after delivery.

    Admire 2 is a pretty nice phone for the $$. @49.99 definitely a deal. Anywhere below 150... Not too bad.
    yeah i was thinking that too. yeah everyone already has 4.1+ phones.. i cant even record a video on insta. with this phone.. xD

    ---------- Post added at 02:56 AM ---------- Previous post was at 02:53 AM ----------

    Quote Originally Posted by Android Titan View Post
    Why don't you load the stock ROM and see what happens or is that what you did

    Sent from my SCH-R530C using Tapatalk 2
    yeah i've been using stock rom for a while now. idk but ive dropped my phone lots of times never any cracks on screen. its a cool phone and i was hoping someone could bring out the beast in it but eh..

  8. #7
    Senior Member
    Points: 22,444, Level: 93
    Overall activity: 0%
    Android Titan's Avatar
    Reputation
    Reputation 52
    Join Date
    Mar 2012
    Location
    portland oregon
    Posts
    761
    Phone
    Galaxy S3



    I've tried oraix123 has tried even PLAYFULGOD its just the way they they coded it , it was all fucked up I mean that shit was coded cockeyd backwards one little file or driver get removed and bame shit won't turn on the first 5 Mercury's I had bricked just from changing the keyboard and download one from Google play wasn't even rooted just chose it as my default keyboard the. Phone turned off and would power back on

    Sent from my SCH-R530C using Tapatalk 2

  9. #8
    Senior Member
    Points: 6,834, Level: 54
    Overall activity: 0%
    dazeone's Avatar
    Reputation
    Reputation 19
    Join Date
    May 2012
    Location
    san antonio
    Posts
    255



    Got to admit the lower end ascend 2 was a die hard phone but the mercury forget it. Like you said change one thing on it and bam paper weight you know have. :banghead:

    sent from Custom Cm10.1 sgs3

  10. #9
    Member
    Points: 2,656, Level: 31
    Overall activity: 0%
    NeoZiggy's Avatar
    Reputation
    Reputation 15
    Join Date
    Dec 2011
    Customer Since
    2010
    Location
    San Antonio, TX
    Posts
    142
    Phone
    Huawei Mercury



    I have to come to the Mercury's defense... I've had mine since it came out nearly two years ago in December. I think later models were the ones with issues.
    I've been rooted since the second week. Later I installed ICS and it lagged a lot. Finally I installed CM10 (Jellybean) that's posted on this forum. The phone resets once in a while but CM10 wasn't made for the US Mercury, it's for it's UK counterpart. I use WiFi calling since this ROM doesn't work on US towers (no data).

    I never had a phone last me this long before! I drop it at least once a day, slam it in anger, shower with it close while streaming music, ect. Maybe I got lucky?
    Last edited by NeoZiggy; 09-08-2013 at 06:36 AM.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Advertise With Us?
Advertise with us? (Position 1 - Advertise with Us) Small Banner