Sign Up Now FAQ
Signup Now
In order to make a post or to start a new thread and or to interact with other
members of this board, you wil need to create an account first.
If this is your first visit, be sure to check out the FAQ. You have to register before you can post. If you have any problems, please contact us.
Flash a phone to Cricket Wireless Become a supporting member of Cricket Users Forum

 
Welcome to Cricket Users!



Results 1 to 10 of 10
  1. #1
    Junior Member
    Points: 629, Level: 12
    Overall activity: 3.0%

    Reputation
    Reputation 10
    Join Date
    Mar 2012
    Location
    El Paso, TX
    Posts
    27



    MMS on cricket [confirmed working on 4.1.1]

    I recently switched to the Samsung Nexus S 4G after having the Huawei Mercury M886 for a year. After a bit of research, I knew that getting it flashed to cricket would not be a problem.
    Before I left, the salesman verified that everything worked, including MMS.
    I had read that MMS is a tough topic, doesn't work, etc.

    So I asked him for the apk, here is the link he provided:
    Flashtotalk Android Site



    My Nexus S came with 4.1.1 and it works perfectly.

    Of course the first thing I did when i got home was root, install CWM, backup my stock ROM and try something new. I went for a 4.2.2 ROM by Slimbean and then downloaded/installed the MMS apk from the above link. It does not work.
    Maybe if I try another 4.2 ROM?

    But since I've just upgraded from Gingerbread on the Mercury to ICS, I'll leave it here for a while.


  2. Remove this advertisement.
  3. #2
    Member
    Points: 6,229, Level: 51
    Overall activity: 0%

    Reputation
    Reputation 20
    Join Date
    Dec 2011
    Location
    United States
    Posts
    140



    This isn't just going to work on anyone's device, it does require the device to be flashed with the Flashtotalk tool. It will fail validation if you have not flashed the phone through there software.

  4. #3
    Junior Member
    Points: 629, Level: 12
    Overall activity: 3.0%

    Reputation
    Reputation 10
    Join Date
    Mar 2012
    Location
    El Paso, TX
    Posts
    27



    Quote Originally Posted by amoamare View Post
    This isn't just going to work on anyone's device...
    Thank you for the details. I'm not aware on how cricket flashing works. I just wanted to share my experience.

    So let me ask you (as you clearly know much more than I), if I wanted to get MMS working on my 4.2.2 ROM, I have to edit the APNs, correct? There's no way around that?!

  5. #4
    Member
    Points: 6,229, Level: 51
    Overall activity: 0%

    Reputation
    Reputation 20
    Join Date
    Dec 2011
    Location
    United States
    Posts
    140



    If your phone was flashed using the Flashtotalk software, you should be able to redownload the apk and install it and it should be working again fine.

    If it fails validation something in the rom is not working as expected and sending wrong information.

  6. #5
    Junior Member
    Points: 629, Level: 12
    Overall activity: 3.0%

    Reputation
    Reputation 10
    Join Date
    Mar 2012
    Location
    El Paso, TX
    Posts
    27



    When I was running 4.2.2 ROM, I was able to successfully download and install the apk. The site has some detection, and it displayed that I was infact on 4.2.2 and downloaded the appropriate ROM. Install went find, but sending fails.
    However the ROM is very minimal (SlimBean 4.2.2 http://goo.gl/D5m5e ) so I'm sure it fails because of something else is required. Maybe if I try CM or AOSP/AOKP ROM, I'll have better luck!

    Thanks for the information amoamare!

  7. #6
    Member
    Points: 6,229, Level: 51
    Overall activity: 0%

    Reputation
    Reputation 20
    Join Date
    Dec 2011
    Location
    United States
    Posts
    140



    One thing you can try to see if it could be this problem, is connect to WIFI and then attempt to send. If it sends the rom builder is missing information in there rom. We have seen some roms state there is no connection to internet and deny Mms but work fine over WIFI (It will simultaneously connect to 3G then send a MMS) it will not send the actual picture over WIFI.

  8. #7
    Member
    Points: 1,697, Level: 23
    Overall activity: 9.0%
    jj9320tsi's Avatar
    Reputation
    Reputation 13
    Join Date
    Apr 2011
    Customer Since
    2008
    Location
    Chicago, IL
    Posts
    47
    Phone
    Galaxy S 3



    I was having the same no MMS problem, after trying APN BACKUP & RESTORE from the market to find out that it's blocked on 4.0+ due to security reasons, I refused to give up and found a post stating that when you combine APN BACKUP & RESTORE and TITANIUM BACKUP*ROOT, it will allow you you to disable the ICS CHECK in APN BACKUP & RESTORE by pressing the menu key allowing you to manipulate and restore your reworked APN file. I'll post the link after I'm done altering mine This is all on the stock 4.1.1 rom

  9. #8
    Junior Member
    Points: 629, Level: 12
    Overall activity: 3.0%

    Reputation
    Reputation 10
    Join Date
    Mar 2012
    Location
    El Paso, TX
    Posts
    27



    Quote Originally Posted by jj9320tsi View Post
    ... when you combine APN BACKUP & RESTORE and TITANIUM BACKUP*ROOT, it will allow you you to disable the ICS CHECK in APN BACKUP & RESTORE by pressing the menu key allowing you to manipulate and restore your reworked APN file. I'll post the link after I'm done altering mine This is all on the stock 4.1.1 rom
    That's the method I did before further messing with my phone.
    I know I did something wrong when I was tinkering with 4.2.2 because on 4.1.1 MMS was working flawlessly.
    Now that I'm back on 4.1.1 it's not working.

    oops. lol.

  10. #9
    Member
    Points: 1,697, Level: 23
    Overall activity: 9.0%
    jj9320tsi's Avatar
    Reputation
    Reputation 13
    Join Date
    Apr 2011
    Customer Since
    2008
    Location
    Chicago, IL
    Posts
    47
    Phone
    Galaxy S 3



    at least you got yours to work on 4.1.1 lol this thing is driving me nuts trying to get it to work but until then I have to send MMS thru GoSMS and receive pics thru the stock app... I just have to get the APNs set accordingly I think

  11. #10
    Junior Member
    Points: 629, Level: 12
    Overall activity: 3.0%

    Reputation
    Reputation 10
    Join Date
    Mar 2012
    Location
    El Paso, TX
    Posts
    27



    Quote Originally Posted by jj9320tsi View Post
    at least you got yours to work on 4.1.1 lol this thing is driving me nuts trying to get it to work but until then I have to send MMS thru GoSMS and receive pics thru the stock app... I just have to get the APNs set accordingly I think
    I tried the GoSMS trick, but it didn't work.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Advertise With Us?
Advertise with us? (Position 1 - Advertise with Us) Small Banner